Fix the Page Elements Layout Editor No Scrollbar Problem. ~ The Blog Doctor.
Loading...

Fix the Page Elements Layout Editor No Scrollbar Problem.

New Visitor? Like what you read? Then please subscribe to my Blog Feed or sign up for Free Email Updates. Thanks for Visiting!

The Page Elements subtab of Layout (previously - Template) tab is used to Add and Arrange Page Elements. Since 12 Feb 2008 there have been no scrollbars in it. This causes the Page Elements on wider templates to disappear below the right edge and bloggers cannot access the Edit button on them. See picture below :



This can be fixed by modifying the CSS part of the template for the wireframe layout editor..............


Follow these steps to modify the code :


1. Login at Blogger.com.


2. Blogger Dashboard page opens for successful login.


3. Click 'Layout' link under your blog title.


4 The Page Elements subtab of Layout tab will open.


5. Click 'Edit Html' subtab of Layout tab.


6. The Edit Html tab will open with the Template Code box.


7. Scroll down in the Template code box till this code : ]]></b:skin>


8. Copy this code :

body#layout #outer-wrapper {
width:760px;
margin-$startSide: 0px;
margin-$endSide: 0px;
}



9. Paste it in the Template Code box immediately above the ]]></b:skin> tag.


10. Save Template.


11. Switch to Page Elements subtab of Layout tab. You should now be able to see all your Page Elements :





Happy Blogging!


49 comments:

rj3sp said...

Thank you very much! This solved the problem which appeared when recently I tried to update my layout.

I encountered, however, a problem: after applying the changes the code was not accepted because of an undeclared variable ($startSide) error. Therefore I omitted the lines
margin-$startSide: 0px;
margin-$endSide: 0px;

The result is now probably not entirely what it should be, but at least the layout page problem is solved.

Thanks,
Rob

Chuck Gates said...

Thanks for trying to help solve this annoying problem, but it didn't work for me. I got an error saying:

We were unable to save your template
Please correct the error below, and submit your template again.
Invalid variable declaration in page skin: Variable is used but not defined. Input: startSide

Any ideas?

Vin said...

Chuck,

Check out the comment by RJ3SP above.

Also in the Variable Definitions section in your Template Code box add these lines :

<Variable name="startSide" description="Start side in blog language" type="automatic" default="left" value="left">

<Variable name="endSide" description="End side in blog language" type="automatic" default="right" value="right">

Matt said...

thanks Vin!

I have been dealing with that problem for a few weeks now.. and appreciate your help with it!

Matt

tomat said...

Well, I don´t understand the need of this change (from blogger, I suppose ) and the result isn´t as good as before (the bar widgets appear above the middle bar ones). And what seems worse: with IE it keeps working fine!

I can´t see any effect with the new vars included.

But now I can at least access all my widgets. Thanks.

Igor Holas said...

vince,
this did not work for me. I am using the Denim template, I have the startSide and endSide variables, etc etc ... my template's width is 1110px. Could that be a problem?
this concerns this blog: asitest.blogspot.com - it is a test site for some revisions I am working on for another blog which however cannot be "played with: as it gets a lot of traffic..

Thanks for helping.

Igor

Vin said...

Igor Holas,

This is your code :

body#layout #outer-wrapper
{
width: 1110px;
}

In the post above I have advised this code :

body#layout #outer-wrapper {
width:760px;
}

Howard said...

Fixed it
thanx

Howard said...

This is Howard again.
Fix worked for one time only and then I'm back to frozen frame. I deleted and re-entered the codes. It worked one time only. I checked the HTML and the code was in there. I am emailing this to you also.

py said...

I've tried the above fixes and different variations of them. Nothing is working. I can see a maximum of 7 sidebar page elements on the page element page. When I first started using this template, I could see all of them. Only in the past two days have they been getting cutoff. Do you have any other ideas?

The template I'm using wasn't provided by Blogger (although its pretty basic) and some things I cannot change certain things (fonts and colors, email links for posts, turn on/off quickedit, stuff like that) via the interfaces provided, so I've been forced to learn XML as I go here.

HAving said that, I'm curious as to why would changing the width of the body affect the height? Probably an obvious answer, but as I said, I'm learning as I go...

TIA!

Darryl

http://bloggerny.blogspot.com

Vin said...

Darryl,

Can you take a screenshot :

Free Screenshots for Bloggers.

and then upload it to a free host :

How to Upload to Free hosting.

and then provide the link to it here so we can analyze the problem.

Bewildertrix said...

Like Darryl, some of my sidebar page elements were cut off two days ago. I cannot scroll down beyond a certain point and there should be another 4 or 5 page elements present.

Screenshot: http://i260.photobucket.com/albums/ii33/BonandCon/MISC/ScreenShot.jpg

http://goblinpoppet.blogspot.com

Any ideas, TIA.

laketrees said...

hello Vin
I am having the same problem with my blogs at laketrees and PoeARTica..
I am using the Tekka template which I have modified...
any advice would be greatly appreciated...as I have tried all of the above
thanks Kim

desperateblogger said...

hello. i have a 2-column template and my problem is the layout/page element page won't scroll down. i cannot edit more than half of the page elements i put up.

help!

Pedro Scormin said...

Hi Vin,
I am also having the same problem. The vetical scroll doesn't go beyond a certain point.
Please, could you help us?
Tks!
Pedro

desperateblogger said...

i also cannot scroll down beyond a certain point. i cannot edit half of my page elements since the since the quick editing is alo not showing. help!

Sukhjinder Longia said...

Thanx a million very easily described got it very quick.
keep it up

Fucc said...

very niceblog, i've used lot of the feature expained here on my reviews site. thanks for the great work!

Howard said...

It works...but only until I leave the page. The codes will not hold.

Then when I try to re-enter I get "Variable is used but not defined. Input: startSide....."

I repeat: codes vanish.

Vin said...

Howard,

Use this code instead :

body#layout #outer-wrapper {
width:760px;
}

SojiRo21 said...

Ok so my page elements are being cut off at the sides, i tried to insert all the codes i saw in this forum, and neither has fixed the problem.

Vin said...

Sojiro21,

I don't see the codes mentioned above in your template!

rossella said...

I've tried the above fixes and different variations of them. Nothing is working. I can't see a all sidebar page elements on the page element page. When I first started using this template, I could see all of them. Only in the past two days have they been getting cutoff.

Vin said...

Rossella,

This is a known bug and the Blogger Team is working on it.

Till then try this : Click the Edit link on the last page element you can see. Popup window will open. Close it. Press Tab key on keyboard. The next Edit link will come into view. Press Tab key again to show next Page Element and so on repeat till the last Page element is seen.

Maria Valéria said...

Hi Vin,

Thanks for trying to help solve this annoying problem, but it didn't work for me.

My problem is the layout/page element: the page won't scroll down. I cannot edit more than half of the page elements I put up. The vetical scroll doesn't go beyond a certain point.

Please, could you help me?

Thanks,
Maria Valéria.

Tanat said...

Vin,

I tried your fix above, but it didn't work for me.

Is there a limit to how many elements we are allowed to add to the template?

When I Edit Layout, I only see the top half of my total elements. The bottom half do not come into view. The scrollbar won't go any further down.

Vin said...

Tanat,

The fix is for the width problem. The Blogger Team is working on the length problem. Till then try the Tab method.

tomat said...

Hi Vin. Thanks again for the Tab trick. It works for me while blogger fixes the problem.

I've noticed another problem when I try to delete widgets: I can create new widgets and modify existing ones, but when I want to remove one from FF, the delete button appears to do nothing and there isn't the normal confirmation window. From IE it works well. ¿Do you konw something about that?

Vin said...

Tomat,

Just delete the widget code line in the Template Code box directly.

tomat said...

Thanks, Vin. It's a good idea, but I don't need it because it's simpler to delete it from IE.

But I'd like to know if it is a known bug of blogger with FF or a problem in my configuration.

Vin said...

Tomat,

Does not occur in my FF2 and have not heard it anywhere else.

V said...

LOVE your blog! I can see all my elements but the footer - "Add New Element" isn't showing? Any ideas.

Vin said...

V,

This problem seems to have recurred again! Try clearing the cache and use Firefox browser.

If that does not help try manipulating the code directly in the Template Code box on the Edit Html tab.

V said...

Tried clearing cache - even tried another computer! Which code shall I manipulate? Have done the bit you suggest at the top.

Vin said...

V,

Can you send me the template? The email addy is in middle column.

Alya Hanis said...

hey, i tried to edit my html codes with others but i cant seem to do it coz it says 'Your template could not be parsed as it is not well-formed. Please make sure all XML elements are closed properly.
XML error message: The element type "head" must be terminated by the matching end-tag "".

Vin said...

Alya Hanis,

What code were you trying to paste in the template?

You may have deleted the </head> tag by mistake.

Alya Hanis said...

hey Vin. i took a blogskin codes from blogskins.com and every html code i try, it says the same thing. my friends dont seem to have that problem.
what am i supposed to do? i really want to change my blog skin

Vin said...

Alya Hanis,

You have to Revert blog to Classic Templates before you try loading a Classic Template.

Sujaco said...

Hi Vin. Thanks for all your hard work. It is much appreciated. Concerning the problem with he page elements --no scroll bar, you suggested:

body#layout #outer-wrapper {
width:760px;
margin-$startSide: 0px;
margin-$endSide: 0px;
}

It wouldn't work for me so I took OUT the:

margin-$startSide: 0px;
margin-$endSide: 0px;

and left just:

body#layout #outer-wrapper {
width:760px;
}


and it works beautifully!

Anonymous said...

Tried inserting the code. Didn't work. Tried Tab Method. Work fine, but not able to add page element.

Vin said...

Anonymous,

After saving changes did you clear the cache?

Use Firefox browser.

Which page element do you want to add - HTML, Text, Picture, LinkList,....?

umipapa said...

vin dear.. i tried most of the method to enable add page element in mine. the "add gadget link' is not there..
i tried the (with n w/out $starside etc..)
body#layout #outer-wrapper {
width:760px;
margin-$startSide: 0px;
margin-$endSide: 0px;
}
tried the maxwidgets='3+1' showaddelement='yes'

and cleared cache but to no avail. pls help, http://www.umipapa.blogspot.com/

i've also deleted my old blog due to this in error. already send request to retrieve at help center.

Vin said...

umipapa,

Use Firefox browser latest version. Also enable Javascript in browser settings.

Anonymous said...

Vin gooday,
Thanks for the good works you are doing.
I've being having problem with the add page element-it is not showing up.I also create another blog but it is equally not displaying add page elemment. i tried the suggested code: body#layout #outer-wrapper {
width:760px;
margin-$startSide: 0px;
margin-$endSide: 0px;
} but all to no avail.I also ommitted the lines:
margin-$startSide: 0px;
margin-$endSide: 0px;
} leaving only: body#layout #outer-wrapper {
width:760px;
but all prove abortive. What do i do.
Thanks
Shina

Anonymous said...

Good day Vin,
I tried the suggested code but it didn't work. The add page element still did not appear. I use DOTS template
What do i do?
Thanks
Shina

Vin said...

Shina,

Are you using Firefox browser on a PC?

The Add Page Element link has been replaced by Add Gadget link.

What is your blog address?

Rachana said...

Hi,
I made many changes to my template, which works fine, but i suddenly noticed that the POST-BLOG element dissappeared from my page layout, though i can all the posts perfectly in the blog.

Please help.

Vin said...

Rachana ,

First Backup gadgets.Then click on 'Revert widget templates to default' link at the bottom of the Template code box on Layout--->Edit Html subtab.

CLICK TO LEAVE A COMMENT..... :-)



Skip to top of post.

Search Blog Before Commenting

Loading...

Post a Comment

Please use the above search box to search this blog before posting your valuable comments.

Comments posted on Dummies Guide to Google Blogger (Beta) are moderated and will be approved only if they are on-topic and not abusive. Try not to include website URLs/links in your comments. You can email me : drbhatns at gmail dot com for any blogging question. Thanks,

Vin.

The Blog Doctor The Blog Doctor2 Blog Doctor Home

SUGGESTED READING

Tips On Blogger and Latest News.



Skip to top of post.